Trouble posting from my PC

I find that when I try to post or edit a previous post from my PC that I get an error message and the post doesn't go through. I can still post from my phone. Has Anyone else had this problem? I tried posting from two different computers and got the same error.

I'm trying from a different browser.

Woohoo! It worked!

EDIT: It seems I am only able to edit previous posts. I can't make new posts.

EDIT: Now it;s not letting me edit posts either, even with the different browser. Somehow it's letting me edit this one post.


EDIT: I used Google Chrome first. It won't let me do anything. Microsoft Edge lets me edit this one post but not other posts. I guess I'll see if I can try another browser.

EDIT: Internet Explorer also won't let me edit other posts.

EDIT: Trying Chrome again. Chrome still won't let me make new posts.

EDIT: Firefox won't let me make new posts either.

What error are you getting? I'm not seeing anything in the spam queue from you.

I get this:

Service unavailable

Righto. I'll send you a PM shortly.

This is a test.